Author Topic: Where's my 12psi gone?  (Read 4138 times)

Marshall

  • 170BHP Member
  • ***
  • Posts: 61
    • View Profile
Where's my 12psi gone?
« on: 09:33, Wed 04 May 2011 »
I seem to have lost 2psi somewhere, the car was running 18psi when last week but for some reason it's dropped to 16.  Only reason I checked is there's an audible difference to the dump valve, before it was obscenely loud and now it's gone really really quiet.  Not sure if this makes any difference or not but Vac wise it was around 25inHG and now it seems to be at 13inHg.

I've had a quick look under the bonnet for air leaks while the car is running, I seem to be getting a hissing from the DV (Forge Motorsport item) on tick over but there's nothing apparent anywhere else.  Could it be letting air in maybe?  Would that cause a loss of PSI?

DaveMayGTT

  • 150BHP Member
  • **
  • Posts: 29
    • View Profile
Re: Where's my 2psi gone?
« Reply #1 on: 12:54, Wed 04 May 2011 »
Does sound like something is leaking, dv is a good place to start.

andybond

  • 200BHP Senior Member
  • ****
  • Posts: 776
    • View Profile
Re: Where's my 2psi gone?
« Reply #2 on: 12:56, Wed 04 May 2011 »
The EU has just banned all dump valves from last week. A new edict came out and is now in force.

At once you need to remove the dump valve and replace either with a mark 1 broom handle or a blanking plate.
 :D

smithyr5gt

  • 200BHP Senior Member
  • ****
  • Posts: 497
    • View Profile
Re: Where's my 2psi gone?
« Reply #3 on: 13:08, Wed 04 May 2011 »
sorry??

we arnt aloud dv's anymore?????
YOU KNOW THE WHITE ONES ARE FASTER!!!

tubbyG

  • 200BHP Senior Member
  • ****
  • Posts: 409
    • View Profile
Re: Where's my 2psi gone?
« Reply #4 on: 13:33, Wed 04 May 2011 »
Quote from: "andybond"
The EU has just banned all dump valves from last week. A new edict came out and is now in force.

At once you need to remove the dump valve and replace either with a mark 1 broom handle or a blanking plate.
 :D

i quite like my dump valve :(

nadgtt1982

  • 200BHP Senior Member
  • ****
  • Posts: 443
    • View Profile
Re: Where's my 2psi gone?
« Reply #5 on: 14:13, Wed 04 May 2011 »
Quote from: "Phase2-tungy-gtt"
Quote from: "andybond"
The EU has just banned all dump valves from last week. A new edict came out and is now in force.

At once you need to remove the dump valve and replace either with a mark 1 broom handle or a blanking plate.
 :D

i quite like my dump valve :(

Computer says noooooooo, i love a dump valve  :mrgreen:

Marshall

  • 170BHP Member
  • ***
  • Posts: 61
    • View Profile
Re: Where's my 2psi gone?
« Reply #6 on: 14:21, Wed 04 May 2011 »
Quote from: "andybond"
At once you need to remove the dump valve and replace either with a mark 1 broom handle or a blanking plate.
 :D

lol, I've actually just got back from trying that, albeit with a Mk2 broom handle.  The vac's back to where it was around the 25inHg area although I still seem to have lost 2psi somewhere...

At least I know the DV is one issue needing looking at.....

andybond

  • 200BHP Senior Member
  • ****
  • Posts: 776
    • View Profile
Re: Where's my 2psi gone?
« Reply #7 on: 16:50, Wed 04 May 2011 »
Dont mess with the EU. They are the law
 :D

Marshall

  • 170BHP Member
  • ***
  • Posts: 61
    • View Profile
Re: Where's my 2psi gone?
« Reply #8 on: 21:17, Tue 17 May 2011 »
OK guys, I'm a bit stumped with this now.  I seem to have lost 4psi now, it's dropped to 14 from 18 with no obvious (to me) reason why.  I've left the DV off now and the Vac reading has stayed the same, I can't hear any obvious leaks coming from anywhere under boost so I'm not quite sure what's what.  Just to add the turbo is relatively new and doesn't smoke.

Anyone give me some pointers on what else to check as I'm still very much a noob to all this turbo malarky.....

fordy

  • 200BHP Senior Member
  • ****
  • Posts: 242
    • View Profile
Re: Where's my 2psi gone?
« Reply #9 on: 21:20, Tue 17 May 2011 »
turbo actuator going weak with old age?

Marshall

  • 170BHP Member
  • ***
  • Posts: 61
    • View Profile
Re: Where's my 2psi gone?
« Reply #10 on: 21:28, Tue 17 May 2011 »
Just messaged the previous owner to check, but from what I'm aware the actuator was included when he bought the turbo.

Edit:  Any idea how I'd check??

DaveMayGTT

  • 150BHP Member
  • **
  • Posts: 29
    • View Profile
Re: Where's my 2psi gone?
« Reply #11 on: 13:15, Thu 19 May 2011 »
Might be worth pressure testing the whole boost system

Marshall

  • 170BHP Member
  • ***
  • Posts: 61
    • View Profile
Re: Where's my 2psi gone?
« Reply #12 on: 14:25, Mon 23 May 2011 »
How would I go about doing that?  Checked with the previous owner about the actuator and he said it was a second hand unit so it could well be that on it's way out (I still can't hear any obvious leaks), if it is where would I buy one from?

Also, down to 12psi now.....

DaveMayGTT

  • 150BHP Member
  • **
  • Posts: 29
    • View Profile
Re: Where's my 2psi gone?
« Reply #13 on: 17:13, Mon 23 May 2011 »
This was some advice on the rtoc recently

"You can test the actuator with an old tyre valve. I used one from an old bmx inner tube.
 Push it over the end of the actuator port and pump it up and see what pressure it opens at and if it holds the pressure."

Marshall

  • 170BHP Member
  • ***
  • Posts: 61
    • View Profile
Re: Where's my 2psi gone?
« Reply #14 on: 00:51, Tue 24 May 2011 »
Genius, shall give that a go over the weekend and see what comes up.