Author Topic: Hello everyone  (Read 2018 times)

eddy_gtt

  • 150BHP Member
  • **
  • Posts: 41
    • View Profile
Hello everyone
« on: 18:56, Thu 17 December 2009 »
Ok, 1st of all i finaly have a 5 gt turbo. 2nd think when i bought the car i had been told its just had a full engine rebuild and all gaskets were brand new. had the car out last night, was out about an hour and bang, bleen nipple blew out of the top rad hase that comes fron the water pump to the radiatort. any one no what i can do to sort this or will i need a new top hase? aint had a chance to look at the car today as i have been at work all day.

i will get some pics up at the weekend :D

r5matt

  • 200BHP Senior Member
  • ****
  • Posts: 837
    • View Profile
    • http://www.renault5gtturbo.co.uk
Re: Hello everyone
« Reply #1 on: 18:28, Mon 21 December 2009 »
Welcome ,

I had this happen! . . New hose is deffo needed my friend , unless the screw was just not done up correctly give the hose a good looking over ,

On a serious note , This is what caused my headgasket failure! so i would Highly recommend giving the little warrior a good checking over !

ATB

Matty

eddy_gtt

  • 150BHP Member
  • **
  • Posts: 41
    • View Profile
Re: Hello everyone
« Reply #2 on: 11:07, Tue 22 December 2009 »
the whole nipple blew out the hose. Ordering a new set of hoses after xmas.
My head gasket has gone aswell, just ordered a k-tec racing upraited gasket kit and head bolts.

Not had a chance for any pics yet.

Any advice on running these would be much appriciated

James5

  • Test
  • Global Moderator
  • 200BHP Senior Member
  • *****
  • Posts: 2772
    • View Profile
Re: Hello everyone
« Reply #3 on: 09:44, Thu 31 December 2009 »
Welcome to the forum matey, not a nice why to start your 5 gtt relationship but we have all been there at somepoint with similar experiences and learnt the hard way.

You need to find out what caused the pressurisation of the hose and caused the nipple to come out or as mentioned above was it merely the fact that the nipple was loose?

When you have the head off check the head for flatness, also check the liners in situ to make sure no cracks.

If you have just got the car personally I never trust who I buy cars off unless i know them and the car's history. Get someone who knows Renault 5's like Markey Mark to have a look and set the car up properly fuel correctly for boost, even do the h/g for you.  Why did the previous owner rebuild it??

eddy_gtt

  • 150BHP Member
  • **
  • Posts: 41
    • View Profile
Re: Hello everyone
« Reply #4 on: 11:05, Thu 31 December 2009 »
Quote from: "James5"
Welcome to the forum matey, not a nice why to start your 5 gtt relationship but we have all been there at somepoint with similar experiences and learnt the hard way.

You need to find out what caused the pressurisation of the hose and caused the nipple to come out or as mentioned above was it merely the fact that the nipple was loose?

When you have the head off check the head for flatness, also check the liners in situ to make sure no cracks.

If you have just got the car personally I never trust who I buy cars off unless i know them and the car's history. Get someone who knows Renault 5's like Markey Mark to have a look and set the car up properly fuel correctly for boost, even do the h/g for you.  Why did the previous owner rebuild it??

i got my 5 back on the road christmas eve :D had to get the head skimmed alot as it was very pitted, fitted a new uprated 1.9mm headgasket from K-TEC racing anso fitted new head bolts. had to flust the engine through as the out was thick and white. now i have had it on the road a week running it al low boost about 8-10psi and all seems fine now.
i have just ordered my self a front mount intercooler, its core size is 550x175x65. i have read the fitting guide on here and no you need to cut the bottom of the crossmember and a bit of the toe eye. when i fit this i will also be re-tightning my head bolts.
then hopefuly in the new year, january if i can afford it i will be ordering a power system group `A`carb from K-TEC Racing

there is something rong with my fueling??? when the fuel light comes on i put 10 worth of petrol in, run it untill the light is back on and put another 10 worth of petrol in and both times from when i put the 10 of petrol in till the light comes on i am only getting 25-30 miles what work out to be around 15mpg max. that is when i am taking it easy. any idea what it could be? there are no leaks in the tank or the fuel system that i can find