Author Topic: Oil level gauge and oil pressure warning light, Help please!  (Read 1396 times)

penfold1981

  • 170BHP Member
  • ***
  • Posts: 131
    • View Profile
well the problem goes like this.

oil level gauge is supposed to come on when ignition is in the on position without engine running, it doesn't work, it just sits at the bottom of the gauge and doesn't even light up the oil level part of the gauge. But the oil pressure gauge is fine.

Also, when the ignition is first turned on the battery, oil pressure and brake warning lights are supposed to light up to check the bulbs but the oil pressure and brake warning light don't come on, brake warning light is easy, the switch on the handbrake is faulty but I can't figure out why the oil pressure warning light doesn't work. I checked the voltage to the lamp socket and for some reason there is around 12v at both sides of the lamp socket!

Anyone got any ideas what the problems could be or if they are related?

Does anyone know how the gauge selects which information to display? Is there a relay or is there some electronics in the dash that may be faulty?

Sorry that was all a bit long winded!

Ash-Lee

  • Global Moderator
  • 200BHP Senior Member
  • *****
  • Posts: 4208
    • View Profile
(No subject)
« Reply #1 on: 23:45, Mon 03 August 2009 »
Mine used to misbehave up until last week. Sometimes they would light up, other times they wouldnt.

What i did was disconnect the multiplug behind the passenger headlight, clean the contacts and spray a little WD40 on them and now my oil guages/lights work perfect!

Might not be the problem in your case but worth a try.

Big Steve Raider

  • 170BHP Member
  • ***
  • Posts: 121
    • View Profile
    • http://s306.photobucket.com/albums/nn259/BigSteveT/Raider/
(No subject)
« Reply #2 on: 11:31, Wed 05 August 2009 »
The gauges are notorious for going wrong?? It may be a problem with the gauge?

penfold1981

  • 170BHP Member
  • ***
  • Posts: 131
    • View Profile
(No subject)
« Reply #3 on: 19:38, Wed 05 August 2009 »
I think I'll have to wait until I have some spare cash and get a used set of gauges from CGB :-)

Thanks guys