Author Topic: Just bought a 1.4 turbo, but not a R5! :(  (Read 6090 times)

kz

  • 170BHP Member
  • ***
  • Posts: 95
    • View Profile
Just bought a 1.4 turbo, but not a R5! :(
« on: 16:59, Tue 07 July 2009 »
Well this came up local and cheap so I went for it, as I need to get from A to B lol. I'm still ultimately on the search for a R5 GTT though :wink:

It only set me back 800 and is said to be running 165bhp with the Seb2 setup... it's a bit marmite so far but whatcha think of my bumblebee :D






scottyp1989

  • 115BHP Newbie
  • *
  • Posts: 4
    • View Profile
(No subject)
« Reply #1 on: 15:58, Tue 13 October 2009 »
looks good mate, always liked these

kz

  • 170BHP Member
  • ***
  • Posts: 95
    • View Profile
Re: Just bought a 1.4 turbo, but not a R5! :(
« Reply #2 on: 11:41, Sat 23 January 2010 »
Hi guys, currently having boost problems, I thought it was the MBC at first, but have now changed that and still getting the same thing.

Basically, it doesn't hold boost. I had it set to 10PSI and it would just about hold. But damn that's slow... I needed to up it to between 15-20PSI which a Seb2 setup can take. I got it to 20PSI and as soon as it hits the mark, it shoots straight down to 10PSI or thereabouts. There is basically no pull on the car after the initial acceleration...

I've been told a new, uprated actuator might help. I've just sent an email to the guys at Turbo Technics as they were recommended to me, as their T2 actuator is meant to fit the standard turbo on Puntos. It seems that after that everyone has run outta ideas! :| so just thought I'd enquire here as obviously you guys know your stuff and you might be able to think of something else!

Cheers.

gt alan

  • 170BHP Member
  • ***
  • Posts: 112
    • View Profile
Re: Just bought a 1.4 turbo, but not a R5! :(
« Reply #3 on: 15:30, Sat 20 February 2010 »
hay man psc member yeah???

kz

  • 170BHP Member
  • ***
  • Posts: 95
    • View Profile
Re: Just bought a 1.4 turbo, but not a R5! :(
« Reply #4 on: 15:49, Sun 21 February 2010 »
Sure am mate.

gt alan

  • 170BHP Member
  • ***
  • Posts: 112
    • View Profile
Re: Just bought a 1.4 turbo, but not a R5! :(
« Reply #5 on: 13:50, Mon 22 February 2010 »
me too  :D

gaz

  • 200BHP Senior Member
  • ****
  • Posts: 240
    • View Profile
Re: Just bought a 1.4 turbo, but not a R5! :(
« Reply #6 on: 01:10, Thu 29 April 2010 »
i had a punto gt3 a few years back & had the same prob. mine was standerd apart from ap clutch & running 18psi on standard set up & standard turbo. these engines will run 18 psi allday long on standard set up there bullet proof internaly...
i had the same problem tho, backing off boost but then the turbo went after a bit = standerd turbo at 18psi  :lol: also u may notice an injector symble flash up on ur clocks now & again? this is down to a vacume fault, there proan for it. if u get this symble check ur vac pipes if u cant find 1 thats blown off then just ignore it. a few of my mates have had punto gt's aswell & all theres did the same???
as for backing off boost watch out for ur turbo on its way out if not then like you say maybe it cud be the actuator? i never got a new turbo on mine after it went i sold the car so never found out if it was another problem??  :)

kz

  • 170BHP Member
  • ***
  • Posts: 95
    • View Profile
Re: Just bought a 1.4 turbo, but not a R5! :(
« Reply #7 on: 17:28, Fri 18 June 2010 »
Changed the actuator in the end but unfortunately it's not helped! I think the turbo's on the way out tbh but I'm lost interest in the car so cba fixing it at this point...

Hopefully getting rid soon anyway if my latest R5 deal pulls through!

5teve L

  • Global Moderator
  • 200BHP Senior Member
  • *****
  • Posts: 3540
    • View Profile
Re: Just bought a 1.4 turbo, but not a R5! :(
« Reply #8 on: 09:14, Tue 24 August 2010 »
Is the standard boost control still plumbed in, this will cause the car to drop back to factory setting.
 Are you sure the car is set up for stage 2 (or whatever) at all, may have been told porkies  :evil:  & thus turning boost up will lead to headgasket faulure or worse due to running lean.

EDIT, just seen this is old, DOH!

kz

  • 170BHP Member
  • ***
  • Posts: 95
    • View Profile
Re: Just bought a 1.4 turbo, but not a R5! :(
« Reply #9 on: 10:46, Tue 24 August 2010 »
Funny I just happen to look on here today. It's not really a "stage 2"... Seb2 is just the name of the Power on the Road chip, but when it was running well it was pretty pokey 8)

There is no standard controller as such, but what's there originally has been overridden. I've basically been running it at around 12PSI for months now, there's not much poke anymore but it will do, and it seems to be smooth enough (just about!) either way hopefully this'll be the last week I have to drive it as my insurance is getting transferred to me R5 next week :)