Author Topic: pipercross viper=dump valve problems???  (Read 4823 times)

dgdogz

  • 200BHP Senior Member
  • ****
  • Posts: 447
    • View Profile
pipercross viper=dump valve problems???
« on: 12:38, Sun 11 May 2008 »
hi ppl
got a dilemma on my hands
im no mechanic
or even close too it

but i baught viper kit for the car...and installed it yesterday...well my mate did
along with it he did oil and oil filter change...put in new ngk platinum spark plugs

but my cars not dumping the same
its really really quiet

before it ws a severe whoosh...now its just a lil hiss
ne ideas????


im kinda stuck coz i reely loved tht sound
hahaha

ne help would be appreciated...thanks ppol


d

smithsgtt

  • 200BHP Senior Member
  • ****
  • Posts: 1021
    • View Profile
(No subject)
« Reply #1 on: 14:26, Sun 11 May 2008 »
is it a recurculating dump vale which means  is there a pipe going from the d/v to the air filter?

or what kind of d/v is there on your car

take a pic and post it up

dgdogz

  • 200BHP Senior Member
  • ****
  • Posts: 447
    • View Profile
(No subject)
« Reply #2 on: 14:45, Sun 11 May 2008 »
im reely not sure wt kind it is
it ws on it wen i got th car
its blue
thats all i kno

it does hav a pipe coming from th top of it
wer it goes im not sure

theres an in car boost valve adjuster thing in the car but i think its screwed coz no matter which way i turn it
nothing changes


my mates comin up tonight with a fairly new forge dump valve so maybe thtl make th difference


hope so

dgdogz

  • 200BHP Senior Member
  • ****
  • Posts: 447
    • View Profile
(No subject)
« Reply #3 on: 15:58, Mon 12 May 2008 »
hey hey
i found out it ws an atmospheric dump valve...
but tht ws bout all

anybody got ne ideas on how to bring back the mighty whoosh???


also the viper really tight to the wheel arch...like the bend in the pipe is mega...would it make a diff if i pointed the viper up a few degrees...so it ws kinda pointing up the way???
thanks

smithsgtt

  • 200BHP Senior Member
  • ****
  • Posts: 1021
    • View Profile
(No subject)
« Reply #4 on: 20:14, Mon 12 May 2008 »
post some pics of the car engine bay and we might be able to help abit more

chrisb

  • 170BHP Member
  • ***
  • Posts: 94
    • View Profile
(No subject)
« Reply #5 on: 23:05, Mon 12 May 2008 »
If the dump valve is not working try looking at the pipe that comes from the base of the carb to the ignition unit, the dump valve should be teed off from there, if it's split or blocked it will be a problem. Also take the dump valve apart to see if the diaphragm is spilt, they usually go around the edge where they are bolted together.

dgdogz

  • 200BHP Senior Member
  • ****
  • Posts: 447
    • View Profile
(No subject)
« Reply #6 on: 10:57, Tue 13 May 2008 »
helloooo
ill get pics asap
my cams on blink...
but it ws working perfectly fine...b4 i put on the viper


???
:)

smithsgtt

  • 200BHP Senior Member
  • ****
  • Posts: 1021
    • View Profile
(No subject)
« Reply #7 on: 11:52, Tue 13 May 2008 »
take the viper off and try it the way it was before

dgdogz

  • 200BHP Senior Member
  • ****
  • Posts: 447
    • View Profile
(No subject)
« Reply #8 on: 12:37, Tue 13 May 2008 »
i myt end up doin tht

i need to adjust the position of the viper neway...
the feed pipe is sitting at a heavy angle becoz the way the old kit ws on

wld it make a diff if i extended the pipe tht holds the viper in place????

cheers

James5

  • Test
  • Global Moderator
  • 200BHP Senior Member
  • *****
  • Posts: 2772
    • View Profile
(No subject)
« Reply #9 on: 23:18, Tue 13 May 2008 »
You will prob find that the viper is muffling the sound more as it is incased.

If it was giving a louder whoosh before and not since fitting that will be why.

WIth regards to re-positioning of the viper don't see why a re-route would be a problem as there isn't much space in the 5 bay for a long pipe run anyway.

Here is a pic of my last R5 with viper psoitioned to the location of the oe intercooler



You can kind of see my pipe run from this pic


dgdogz

  • 200BHP Senior Member
  • ****
  • Posts: 447
    • View Profile
(No subject)
« Reply #10 on: 09:15, Wed 14 May 2008 »
yeh
thts wer i planned to put the feed ....jus under the bonnet....dunno wer to put it
i wsnt sure if i extended the filter part too far away from the turbo it wld affect performance.


???
cheers man
ill b posting my pics up asap

dgdogz

  • 200BHP Senior Member
  • ****
  • Posts: 447
    • View Profile
(No subject)
« Reply #11 on: 12:19, Thu 15 May 2008 »
4364 james


quik question
do you still get a rather loud dump when shifting gears??
or is it really muffled???
thanks

btw apologies for the last reply to this post i read it there and it ddnt make sense....
hahaha
cheers

James5

  • Test
  • Global Moderator
  • 200BHP Senior Member
  • *****
  • Posts: 2772
    • View Profile
(No subject)
« Reply #12 on: 13:37, Thu 15 May 2008 »
Quote from: "dgdogz"
4364 james


quik question
do you still get a rather loud dump when shifting gears??
or is it really muffled???
thanks

btw apologies for the last reply to this post i read it there and it ddnt make sense....
hahaha
cheers



To be honest that was my old car but if memory serves me correctly I had an atmosphere type baileys piston D/V which was fairly loud.

5teve L

  • Global Moderator
  • 200BHP Senior Member
  • *****
  • Posts: 3540
    • View Profile
(No subject)
« Reply #13 on: 14:58, Thu 15 May 2008 »
Quote from: "smithsgtt"
take the viper off and try it the way it was before


I agree, put it back to the way it was & see if the problem stays or not, if it does then you must have put something on wrong or disturbed something i'd say.

5teve L

  • Global Moderator
  • 200BHP Senior Member
  • *****
  • Posts: 3540
    • View Profile
(No subject)
« Reply #14 on: 15:01, Thu 15 May 2008 »
Quote from: "dgdogz"

also the viper really tight to the wheel arch...like the bend in the pipe is mega...would it make a diff if i pointed the viper up a few degrees...so it ws kinda pointing up the way???
thanks


Does that mean the pipe is squashed or pinched so & isn't round ??
If so it's causing a big restriction on the turbo so may be the cause.[/b]