Author Topic: Running problems  (Read 3103 times)

R5gttDJ

  • 130BHP Member
  • *
  • Posts: 19
    • View Profile
Running problems
« on: 17:50, Sun 22 July 2012 »
Need help people!!! Just fitted a new turbo to my car it's been sitting for about a year, took it out once fitted and when I put the boot down it sort of stuttered and popped and wouldn't go as per usual, fuelling maybe?? How could I sort this?
Help appreciated thanks Dylan

markey mark (bd)

  • Global Moderator
  • 200BHP Senior Member
  • *****
  • Posts: 1851
    • View Profile
Re: Running problems
« Reply #1 on: 22:21, Sun 22 July 2012 »
What did the boost gauge do, did it shoot up? Might be over boosting and the overboost kicked in
BD Autosport - Renault 5 gt turbo tuning and repairs.

R5gttDJ

  • 130BHP Member
  • *
  • Posts: 19
    • View Profile
Re: Running problems
« Reply #2 on: 12:08, Mon 23 July 2012 »
Yeah the boost went up, couldn't really concentrate on the gauge however to see how much it went up! would this cause my car to do this because the turbo is at a higher psi than my old one so this sounds like it could be the problem.
Thanks

R5gttDJ

  • 130BHP Member
  • *
  • Posts: 19
    • View Profile
Re: Running problems
« Reply #3 on: 12:10, Mon 23 July 2012 »
Would i simple turn the boost down via the actuator to sort this?

markey mark (bd)

  • Global Moderator
  • 200BHP Senior Member
  • *****
  • Posts: 1851
    • View Profile
Re: Running problems
« Reply #4 on: 16:04, Mon 23 July 2012 »
Quote from: "R5gttDJ"
Would i simple turn the boost down via the actuator to sort this?

Yep turn the boost down with the actuator mate, see how it goes then
BD Autosport - Renault 5 gt turbo tuning and repairs.

R5gttDJ

  • 130BHP Member
  • *
  • Posts: 19
    • View Profile
Re: Running problems
« Reply #5 on: 16:06, Mon 23 July 2012 »
Thanks for the quick reply mate