Author Topic: AEM AFR kits issues... (video included with bonus :P)  (Read 3136 times)

s3irios

  • 170BHP Member
  • ***
  • Posts: 117
    • View Profile
AEM AFR kits issues... (video included with bonus :P)
« on: 11:26, Thu 21 June 2012 »
Hello again my fellow 5ers'.  Just got and installed my AEM afr wideband kit.
Since then i have issues with the readings. On idle it shows high 17s to no reading ( - - - )
, cruising jumps all over the place but mainly low, from 14.8 to 11. On full boost not full revs though it shows 10-11. I know car is running rich, i remeber checking the jets finding them ok with a drill bit set but i may have been wrong so i need to check it out again. Still i know i'm running rich cause spark plugs keep blackening and fuel consumption is really big.

Got a video here, just some cruising and the weird readings. (bonus on 2.29 mark u can hear me saying "wtf" :P)


s3irios

  • 170BHP Member
  • ***
  • Posts: 117
    • View Profile
Re: AEM AFR kits issues... (video included with bonus :P) *Updat
« Reply #1 on: 15:19, Fri 22 June 2012 »
OK, so:

1) got the carb out, cleaned it thoroughly, checked all jets (except the 1st stage, stupid of me)
2) soldered and drilled a/c at 1.1 so i can get a bit more rich mixture at fot.
3) drilled second stage to 1.1 too
4) main jet is standard 1.2 checked it with drillbits.
5) theres no leak on carb or base, quadra checked...
6) cleaned the air filter (had 8 months to do that)
7) did a "trick" about cleaning the platinum spark plugs (didn't check them though so theyre probably blackened) with the partial removal of spark cables so an arch happens in between. Been told that it works.
8) finally fixed PERFECT idle (thanks aem uego i love you), 900 rpm with 14-15 afr readings al the time, and it sounds beautifully.

SO still have one MAJOR issue, it's SUPER rich on cruise. like 10.4 all the time, when i'm boosting it goes up a bit for a second to 12 then on full boost 10.8-11.6.As i said Main jet is standard so HOW THE HELL IS THIS HAPPENING AAAARGHHHHHHHHHHHH!!!
Read that 1st stage jet (which i forgot to check) isn't on cruise but on beginning of boost, so it's not the one to blame.
Don't want to change spark plugs just yet (have them only 5 months) cause if it is still in the rich side when i do i will destroy the new ones too.

Any info would be greatly appreciated.

DIZZY DAZZLER

  • 130BHP Member
  • *
  • Posts: 10
    • View Profile
Re: AEM AFR kits issues... (video included with bonus :P)
« Reply #2 on: 13:29, Tue 10 July 2012 »
Sorry to highjack your post but I am also thinking of fitting a wideband AFR system, however will the sensor fit in to the threading that we already have on the turbo downpipe, if so will it be a good enough and have anough room?

Also there appears to be a lot of talk about the first and second stage jets and how the 2nd stage jet plays a big part on mid boost etc, where is this second stage jet as I believe my current Group A carb has a 0.9 air corrector jet and the larger 1.3 main jet however the rest i believe is standard. Would tweaking the second stage bring my T2/T25 stage two turbo on boost earlier as it feels laggy to me still.

markey mark (bd)

  • Global Moderator
  • 200BHP Senior Member
  • *****
  • Posts: 1851
    • View Profile
Re: AEM AFR kits issues... (video included with bonus :P)
« Reply #3 on: 17:27, Tue 10 July 2012 »
Quote from: "DIZZY DAZZLER"
Sorry to highjack your post but I am also thinking of fitting a wideband AFR system, however will the sensor fit in to the threading that we already have on the turbo downpipe, if so will it be a good enough and have anough room?

Also there appears to be a lot of talk about the first and second stage jets and how the 2nd stage jet plays a big part on mid boost etc, where is this second stage jet as I believe my current Group A carb has a 0.9 air corrector jet and the larger 1.3 main jet however the rest i believe is standard. Would tweaking the second stage bring my T2/T25 stage two turbo on boost earlier as it feels laggy to me still.

If you have a bung welded into the downpipe already yes the sensor will fit into the dowmpipe

If you got a grp A carb thgen i would say remove it and fit a standard carb of at least fit a standard size venturi. II read your other threads but after reading this i can see the problem, it sounds like its running out of fuel if it holding back so its going lean  :(   The enrichment side of the carb (2nd stage jet) is where you want to mod the carb and leave the main jet along. The 2nd stage jet is the fixed one behind the triangle body on the carb fixed into the carb body, this is the jet you need to drill
Fitting a smaller ac jet is ideal too but to know what size you need you ideally need to know what the AFR's are
BD Autosport - Renault 5 gt turbo tuning and repairs.

markey mark (bd)

  • Global Moderator
  • 200BHP Senior Member
  • *****
  • Posts: 1851
    • View Profile
Re: AEM AFR kits issues... (video included with bonus :P) *Updat
« Reply #4 on: 17:31, Tue 10 July 2012 »
Quote from: "s3irios"
OK, so:

1) got the carb out, cleaned it thoroughly, checked all jets (except the 1st stage, stupid of me)
2) soldered and drilled a/c at 1.1 so i can get a bit more rich mixture at fot.
3) drilled second stage to 1.1 too
4) main jet is standard 1.2 checked it with drillbits.
5) theres no leak on carb or base, quadra checked...
6) cleaned the air filter (had 8 months to do that)
7) did a "trick" about cleaning the platinum spark plugs (didn't check them though so theyre probably blackened) with the partial removal of spark cables so an arch happens in between. Been told that it works.
8) finally fixed PERFECT idle (thanks aem uego i love you), 900 rpm with 14-15 afr readings al the time, and it sounds beautifully.

SO still have one MAJOR issue, it's SUPER rich on cruise. like 10.4 all the time, when i'm boosting it goes up a bit for a second to 12 then on full boost 10.8-11.6.As i said Main jet is standard so HOW THE HELL IS THIS HAPPENING AAAARGHHHHHHHHHHHH!!!
Read that 1st stage jet (which i forgot to check) isn't on cruise but on beginning of boost, so it's not the one to blame.
Don't want to change spark plugs just yet (have them only 5 months) cause if it is still in the rich side when i do i will destroy the new ones too.

Any info would be greatly appreciated.

I would change the 1st stage back to a 1mm jet, this will help you out with your problem there shouldn't be any reason to increase it i've know people to make it smaller to help out on cruising fueling  :wink:
BD Autosport - Renault 5 gt turbo tuning and repairs.

s3irios

  • 170BHP Member
  • ***
  • Posts: 117
    • View Profile
Re: AEM AFR kits issues... (video included with bonus :P)
« Reply #5 on: 00:30, Thu 12 July 2012 »
Didn't do anything to 1st stage, plus it didnt seem drilled. (i kinda think i double shecked it with a drill bit, but hey worth checking again and maybe redrill it to 0.9 or something.)
*I actually put a new smaller main jet i thought it might help, i put a 115, but still same afr readings on cruise.
* Changed the idle jet too i had the small rocket thingy inside that missed so i bought a new one and replaced, but no change there too.
*Checked the enrichment lever by adjusting it with a 5mm drill bit on the bottom of the carb .Thought it might open too soon and caused the rich afrs, but no luck there either.
*Recieved new magnecor leads from bay, well was gonna buy em anyway but didnt help on this problem.
*readjusted valves yesterday to 20-25 they were claping a bit, they don't now but still issue with the rich afr...
* As i said to my other similar port to rtoc, the 2nd previous owner said that have put a 1st stage cam on it. haven't checked and don;t know really but there is a possibility it is messing my afrs if its true i guess.
One thing left is the fuel pressure regulator maybe it's faulty? and gives more fuel than it should? I know gotta measure it but dont have a spare psi meter atm...