Author Topic: my clio gt turbo  (Read 1533 times)

JGriffin

  • 150BHP Member
  • **
  • Posts: 24
    • View Profile
my clio gt turbo
« on: 14:10, Mon 04 May 2009 »
i have recently put a 5 turbo lump in my clio. it hs come to the time were i see if it works or it doesnt. at the mo it doesnt it turns over, has a spark, it got fuel but it wont start. all i get is a puff out the carb and hissin and every now n then a bang out the exhaust. has any one got any idea of wot mite be the problem.

Ash-Lee

  • Global Moderator
  • 200BHP Senior Member
  • *****
  • Posts: 4208
    • View Profile
(No subject)
« Reply #1 on: 18:13, Mon 04 May 2009 »
HT leads on the correct way?

Have you messed with the timing at all?

r5gtt08

  • 200BHP Senior Member
  • ****
  • Posts: 706
    • View Profile
(No subject)
« Reply #2 on: 18:37, Mon 04 May 2009 »
most deffinately the firing order sounds the wrong way round!

or could be your timing but i would deffo say the firing order matey :wink:
DONT KNOCK IT TIL YOU TRIED IT!!!!!!!!!

JGriffin

  • 150BHP Member
  • **
  • Posts: 24
    • View Profile
(No subject)
« Reply #3 on: 20:34, Mon 04 May 2009 »
it was mate the order was fucked up lol bad times thnx soo much lads uve made my day she ran sweet as a nut thnx

cavsri130

  • 200BHP Senior Member
  • ****
  • Posts: 344
    • View Profile
(No subject)
« Reply #4 on: 21:05, Mon 04 May 2009 »
you got any pics of it?
IF IN DOUBT FLAT OUT!

JGriffin

  • 150BHP Member
  • **
  • Posts: 24
    • View Profile
(No subject)
« Reply #5 on: 23:04, Mon 04 May 2009 »
yes i have i will put a load for for u too have look at my work lol ill probs do it tomoz if i remember i got to clean it first tho it pritty rejected at the mo lol