Author Topic: Dikkys 1989 5 GT  (Read 6730 times)

dikky

  • 170BHP Member
  • ***
  • Posts: 65
    • View Profile
Dikkys 1989 5 GT
« on: 22:13, Sun 03 May 2009 »
Hi all. heres a little bit of info about me n my 5. my 1st car was a 5 1.1 campus. i instantly fell in love!!!! was sad 2 see it go when i got a company car. heres a pikky o it day after id finnished my work makin it a gtt replica.



so when i got bored of a e30 i bough 4 a laff a few years l8r i returned to 5s!! this time a phase 2 gt!!! i bought it with blown turbo, slipping clutch, lots of rot and niggles. put few quid in2 her n a ktr 180 turbo n boy was that a gr8 fun lil car!!!! here she is....



mad big mistake then and sold her....... had few cars since like wrx, rx7, mini, astra gte and now iv finally corrected my mistakes and bought a 5 again in march!!!! here she is

130k, stainless exhaust, 15s only mods when i got her!!! full rebuild a 100k 2 so fingers crossed!!!

since buying her 4 a track toy/ hobby iv put a few quid in2 her. ktr double sized intercooler 1st purchase, low temp fan switch and ktec re-jetted carb and fitted in car boost 4 me. now fitted me private plate to it and i am currently getting a new standard bumper sprayed to replace damaged on on the car!

if any1 was at ists at donny on the sat u may have seen the old tuby on the track........ mucho funo. hope u enjoy me piccys as much i love drivin her!!!!

i will try and keep topic up 2 date as much as possible so u guys can see the fossils progress!!!





if there aint no rust it aint worth drivin!!

dikky

  • 170BHP Member
  • ***
  • Posts: 65
    • View Profile
(No subject)
« Reply #1 on: 22:16, Sun 03 May 2009 »
o i. im not dyslexic or anything like that jus spilt coffe on my laptop so some times it doesnt type all the letters i want!! sorry!!!

Removed anti perc fan 2day too wasnt workin then decided to run perminantly so i have removed it as shud b ok without
if there aint no rust it aint worth drivin!!

OLLIe

  • 170BHP Member
  • ***
  • Posts: 130
    • View Profile
(No subject)
« Reply #2 on: 23:06, Sun 03 May 2009 »
nice looking 5 :D
1990 Glacier White Phase 2 GTT
2000 Rheims Blue Lancer Evolution VI

dikky

  • 170BHP Member
  • ***
  • Posts: 65
    • View Profile
(No subject)
« Reply #3 on: 23:55, Fri 08 May 2009 »
serviced car today. oil filter came off in my hand so im glad i serviced it when i did as it wasnt tight at all!! also fixed the speedo for the second time. im hoping its fixed for good know as this is the 2nd time iv tightened up a loose connection in the lil black plug on the speedo cable attached to the back of the oe airbox. it didnt seem that loose today but after cleaning up contacts again and tightening connections  again, few cable ties to make sure cable was routed tidy again and it startd working again. hopefully thatsit sorted or i may have to presume the loose connection is another more arkward place!!!!

also 2 wheel bearings been ordered for back as they rstarting to get noisey, so ill get some new grooved disks and new pads and iff the old commision stretches far enuff get sum new shocks n adjust the torsion bar at all the same time so lets hope mr darling is lil generous on this months tax bill!!!
if there aint no rust it aint worth drivin!!

sparkysparks

  • 200BHP Senior Member
  • ****
  • Posts: 967
    • View Profile
(No subject)
« Reply #4 on: 01:34, Sat 09 May 2009 »
thats lookin fine my man, ive never seen a red one.
did you say you got bored of an E30, what did u have?
My speedo doesnt work now either, gonna have to investigate that.

dikky

  • 170BHP Member
  • ***
  • Posts: 65
    • View Profile
(No subject)
« Reply #5 on: 10:56, Sat 09 May 2009 »
had a 4 door 325i, standard with a ecu chip. pulled 190bhp on rollers. fun but i then again wasnt the car i wanted.......... fc rx7 and s13 200sx i had both were more fun........ yet none of them i love like my 5s!!!



if there aint no rust it aint worth drivin!!

sparkysparks

  • 200BHP Senior Member
  • ****
  • Posts: 967
    • View Profile
(No subject)
« Reply #6 on: 14:00, Sat 09 May 2009 »
theyre lookin well nice aswel, im after a 300zx next year, when i can bring myself to get rid of my E30, i have a 318is, not to fast, but its fun.
Good luck with your 5

BriC

  • 200BHP Senior Member
  • ****
  • Posts: 444
    • View Profile
(No subject)
« Reply #7 on: 18:48, Sat 09 May 2009 »
RX7 looks nice!

dikky

  • 170BHP Member
  • ***
  • Posts: 65
    • View Profile
(No subject)
« Reply #8 on: 22:28, Sat 09 May 2009 »
it was. regret i sold it. i got offered to many s to keep it tho!!! was a 50thou mile minter. ahhh well jus the 5 now.... im not 2sorry!!
if there aint no rust it aint worth drivin!!

bazr5gtt

  • 200BHP Senior Member
  • ****
  • Posts: 1003
    • View Profile
(No subject)
« Reply #9 on: 04:49, Tue 12 May 2009 »
nice collection of cars mate especially the 5s 8)

dikky

  • 170BHP Member
  • ***
  • Posts: 65
    • View Profile
(No subject)
« Reply #10 on: 00:45, Wed 20 May 2009 »
did some work on 5 today. tidyd few wires away that arent connected to anything after removing the anti perc fan. also had a look at my fan belt and found out i need a new 1 after me valeting the engine bay (after my small heatshield fire at donnington) the fan belt is now slipping i think. well batter light is flashing when cars at high revs n hits a bump so i think its that slippin or iv got a loose connection somewhere.

heres a pikky or 2 of the engine bay.........





o i took some photos of what happens when being towed by a solid steel tow bar goes wrong!!!!! a new bumpers in the bodyshop now.



if there aint no rust it aint worth drivin!!

5-Mission

  • 200BHP Senior Member
  • ****
  • Posts: 582
    • View Profile
(No subject)
« Reply #11 on: 01:03, Wed 20 May 2009 »
The white one i take it was the GTT replica? You did a good job! The only external giveaway are the non-opening rear windows - people forget them when making replicas!
Did you fit electrics up front as well?

dikky

  • 170BHP Member
  • ***
  • Posts: 65
    • View Profile
(No subject)
« Reply #12 on: 10:51, Wed 20 May 2009 »
white one was few years ago. eerm 5 i think. was a standard 1.1 campus with a donor stolen recoverd crashed damaged 5 gt t. bodykit was repaired and resprayed in three weeks yet i took nearly 6 months to fit it as i got a company car. neva actually drove the car more than 3 miles in this state. as soon as i finnished, i put it up for sale. so it was a 1.1 with a rage 5inch outward rolled loud as and slow as replica lol. sooo i had it tho as it gave me the 5 bug!!!
if there aint no rust it aint worth drivin!!

dikky

  • 170BHP Member
  • ***
  • Posts: 65
    • View Profile
(No subject)
« Reply #13 on: 23:01, Tue 09 June 2009 »




2 vids of me @ pod on rtoc day. run 15.4 consistantly. not bad, pretty happy due to slippin clutch.
if there aint no rust it aint worth drivin!!

DanielSon-gtt

  • 200BHP Senior Member
  • ****
  • Posts: 970
    • View Profile
(No subject)
« Reply #14 on: 00:31, Wed 10 June 2009 »
cant view these
is it just me or anybody else
Go Boost Or Go Home