Author Topic: My Clio Gtt (W.I.P)  (Read 9013 times)

Bass J

  • 200BHP Senior Member
  • ****
  • Posts: 202
    • View Profile
(No subject)
« Reply #30 on: 20:35, Wed 22 April 2009 »
Well since the last update ive moved a lot of pipes about ...and got this -



Im happy to report that it now idles itself ..all i did was clean out the idle jet and fitted a new distributor cap and arm.  

Engine runs but it needs setup badly ..the timings out and the fueling is needing set  :?

Also went and purchased a half cage ...painted it pink  :lol:



Will get this welded in when the car gets out the garage under its own steam  :)



And today i got all my guages together ...tested them and they work properly  8)



I also filled up the coolant and bled it ...it sits at 80 degrees no problem  8)

Iam in the middle of wiring up a manual fan switch as i aint using the gtt loom.

Also when it was running i noticed an oil leak from the oil filter ...so another thing to sort ..also need to sort the noisey starter motor ...its hard to get into with the turbo being in the way
 :lol:

Thats all i have today folks ...next update should be a vid of it driving out my garage after 6+months of sitting  8)

cavsri130

  • 200BHP Senior Member
  • ****
  • Posts: 344
    • View Profile
(No subject)
« Reply #31 on: 06:33, Thu 23 April 2009 »
good stuff mate, feels good when you make a leap forward eh? i wrote a list of stuff i need to do to my car, just little things oh and an mot!
IF IN DOUBT FLAT OUT!

Bass J

  • 200BHP Senior Member
  • ****
  • Posts: 202
    • View Profile
(No subject)
« Reply #32 on: 14:07, Sun 26 April 2009 »
aye man ....just dying to get it on the road...this is my first day off in 2weeks ...so im going to get cracking with it soon ...got a wee hangover at the mo to sort first :lol:

Bass J

  • 200BHP Senior Member
  • ****
  • Posts: 202
    • View Profile
(No subject)
« Reply #33 on: 20:30, Tue 05 May 2009 »
Well today it was raining ...but i had another day off ..so decided to get cracking with betty :)

First off i had to jack the car back up again ..and tighten/seal all the joins on the exhaust.

Secondly i had to sort the loud starter motor as it was grinding off the flywheel. was a coont as i had to get the starter heatshield off ...after a bit of swearing and cut arms i got it off lol.

Sorted both of them :)

Then put some fuel in betty as she was empty.

Started her up ..and it sounded good :) ..soo good i took a few vids.

http://www.youtube.com/watch?v=Rv6PdGzqP1s

and

http://www.youtube.com/watch?v=67me5uepDvg

In one vid the car struggles ..its due to having a de-chocked carb so startup is rough.

All ive got to do is fit a new accelerator cable and tax it ...then get the carb set up and she's ready! :D  :D  :D

Bass J

  • 200BHP Senior Member
  • ****
  • Posts: 202
    • View Profile
(No subject)
« Reply #34 on: 13:57, Thu 28 May 2009 »
a wee update for here :)

I had the RTOC chairman(Miller) round to have a look at my engine .. a few pipes he had to be moved.. said i did well just by looking at pictures. He also set my idle speed to normal and adjusted the fuel mixture.. also sorted my throttle cable so it was working effectively.

He's going to setup the boost at a later date..but has got me to sort a few things out like add the coolant canister again so the system self bleeds from pressure as i had a straight running pipe.

When he brought the idle speed down we heard a knocking noise coming from the waterpump area. So i took the belt off ..started it up and the noise disapeared and then came back. So wasnt sure if it was the waterpump ..looked on RTOC and they said it could be the timing chain tensioner ...so i went out and baught a new waterpump,chain and tensioner.

Ive fitted the new waterpump already...also fitted a new thermostat. On todays menu is fitting the new chain and tensioner ...aint done it before ..so its gunna be a challenge :)

Thats all for just now ..hopefully next week ill have it out for MOT :)

Bass J

  • 200BHP Senior Member
  • ****
  • Posts: 202
    • View Profile
(No subject)
« Reply #35 on: 14:52, Thu 20 August 2009 »
Just realised i aint updated this in agees  8)

The car is now MOT'd & taxed ...i blew my t25 turbo on the way to the mot station due to oil starvation i recon..causing a massive oil leak. Resulting in having to re-gasket the whole bottom end. Im also running a 1.2 clio gearbox at the mo ..tis fun

Im now running a t2 turbo at 8psi.

It needs set up properly with some decent boost i recon  :lol:

Here's a few pics -





Soon to come ..half cage ..1bar boost and some exterior changes :)

Bass J

  • 200BHP Senior Member
  • ****
  • Posts: 202
    • View Profile
(No subject)
« Reply #36 on: 21:18, Wed 14 October 2009 »
Well i aint posted pics up as it hasnt moved much if im honest ....the carb needs a service ..im getting the parts at the end of the month  :)

I have some vids of this ...the carb is fooked and overfuelling like hell lol ..reason for flames lol i have sorted this by the rule of the thumb technique-

A launch vid -
http://s39.photobucket.com/albums/e167/ ... 301432.flv

A rev/flame vid lol -
http://s39.photobucket.com/albums/e167/ ... 301435.flv

a random reverse and a pop vid(this was by mistake ..note my sister shitting herself LOL) -
http://s39.photobucket.com/albums/e167/ ... 301434.flv

A vid of it passing -
http://s39.photobucket.com/albums/e167/ ... 301433.flv

And some pics of it -



This is it running 8psi ...cars fully stripped and not running great ...my plans ...

Full service inc plugs,leads and fuel filter
Carb Overhaul/Service
Full coolant flush as i have new pipes waiting for it.
Get proper boost pipes made up for my FMIC.
Then when im happy ..turn the boost up a wee bit :)
Get the pink half cage fitted ...but before ..spray the inside all black and grind the rust down.
New front end to tidy it up a bit :)
And last but not least Toyo r888's to be wrapped around my wheels :D

Bass J

  • 200BHP Senior Member
  • ****
  • Posts: 202
    • View Profile
Re: My Clio Gtt (W.I.P)
« Reply #37 on: 18:15, Sun 08 November 2009 »
well well ...i aint updated this in a long long time  :lol:

ive since got myself a job so been spending my cash on this wee slag again :)

Since the last time i did a carb service/overhaul ...i did not too bad ..well ...i did put the float on the wrong way (thanks reco for sorting it LOL) ..so it resulted in the engine getting flooded in petrol ..so it cleaned the bores and rings of oil. Which then resulted in the pistons sqweeling :( and lots of smoke from the exhaust. I changed the HT leads to Lucas leads...whiche a blue :) ..should go nicely with my boost hoses when i hook the FMIC up  :P

So today i got up and did an oil and filter change and took the king lead off ..cranked it over to get the oil flowing (again cheers for the advice again reco :) ) .....the sqweeling noise went away and it ran no problems. It then however smoked like a coont ...so i took it a drive  ..it smoked a lot! It looked the same as it did coming out the Mot station with a f**ked turbo LOL ...so ive put it down the turbo  :lol: :lol:   ..im currently trying to source another turbo for it .. but the engine didnt stall when coming to junctions and the engine ran smooth on its drive  :D :D :D  

I also sprayed my rocker cover pink/black...i call it pinkoflage ..looks more purple in the pics  :lol: ,yesterday i had to get a new sunroof as my old one was covered in silicone :( ...made it look crap ..with having the sunroof off i decided to paint the roof black again :)

Anyways here's some pics of how its currently sat :) :) :)










Thanks for reading :)

baptie0

  • 150BHP Member
  • **
  • Posts: 22
    • View Profile
Re: My Clio Gtt (W.I.P)
« Reply #38 on: 21:13, Sun 15 November 2009 »
Clio looks like good fun  8)

i am doing the same conversion on a kreg 4door.
did you have any bother getting an mot without a cat?

Bass J

  • 200BHP Senior Member
  • ****
  • Posts: 202
    • View Profile
Re: My Clio Gtt (W.I.P)
« Reply #39 on: 21:44, Wed 18 November 2009 »
Mine went through an mot without a cat ..i was told they only test it on the age of the engine ....as my engine was a pre 1993 engine it didnt get the cat test. All mot stations are different ..your best bet would to go ask your mot station for information  :wink:

And cheers for the comments  :)

baptie0

  • 150BHP Member
  • **
  • Posts: 22
    • View Profile
Re: My Clio Gtt (W.I.P)
« Reply #40 on: 22:51, Wed 18 November 2009 »
Quote from: "baptie0"
Clio looks like good fun  8)

i am doing the same conversion on a kreg 4door.
did you have any bother getting an mot without a cat?

ok cheers.

Bass J

  • 200BHP Senior Member
  • ****
  • Posts: 202
    • View Profile
Re: My Clio Gtt (W.I.P)
« Reply #41 on: 13:57, Sun 10 January 2010 »
Well ..ive left it sitting for 2months in the cold ..as the turbo's fooked  :lol:  :lol:

So yesterday i decided to get the fooker runnning as in this weather i didnt want the wee bugger dying on me :)

So i had to rebolt the old turbo on ..which is fooked ...just to get it running ...the engine ..pipes and everything had ice on it ..it was doubtfull it started tbh ... so i connected the battery back it ...turned the key ...took a wee bit to start ..but it fired into life  :D  :D  ..good auld c1j lump  8)

Turbo ...fucked much? LOL -


And a wee vid ..as i decided to do a stars in their eyes appearance  :lol:  :lol:


Smokey smokey!

Got two standard turbo's coming from ireland ...decided to buy two so i had one spare just incase :) ...payed for them on boxing day ...turns out the guy forgot to send them and they are 20miles from his house and he doesnt have a car. So implaying the waiting game now  :(

Since this thread ive fitted a new heater matrix ..also got the coolant pipes from a 21k 5gtt that i stole bits from as it was going to the scrappage scheme  :(  ...so ill have heat again :D ...then all ive got to do is fit the interior again ..aka 2seats ..carpet and front doorcards  :lol: