Author Topic: My Clio Gtt (W.I.P)  (Read 8953 times)

Bass J

  • 200BHP Senior Member
  • ****
  • Posts: 202
    • View Profile
(No subject)
« Reply #15 on: 18:05, Sun 08 February 2009 »
Thought id update you all -
This is my dash ...custom made by me for weight saving :lol: -


Also all pipes on and intercooler pipes chopped to size -

Another pic -


Also the water de-gass pipe has been straightened up before someone comments :)

Also as you can see by them pics i got the turbo span ok ...courtesy of your lovely help on this forum :) Thanks!

A quick rundown of whats been done -

 Well heres todays progress....

Its all wired up courtesyof my mate reco ...bar the fuel pump and radiator ...we are just going to put switches on the dash for them :)

The coil has power,starter has power ...it cranks over ...it just doesnt start. We inspected that the coil wasnt producing a spark which we recon is down to the TDC sensor. Ive been told that my TDC sensor from my old engine will fit.

The exhaust is all bolted on aswell. We had to take intercooler off to get into the alternator so ill have to hook that back up. Also im going to fluid the car up ..inc fuel aswell.

So progress is good with my clio.. hopefully it will be running next weekend :)

No pics as there isnt much to see :lol: ..thanks for reading :)

sonic-jdm

  • 200BHP Senior Member
  • ****
  • Posts: 179
    • View Profile
(No subject)
« Reply #16 on: 15:28, Mon 09 February 2009 »
Nice project fella, keep up the good work. keep us posted when you get it started :P

reco

  • 115BHP Newbie
  • *
  • Posts: 3
    • View Profile
    • http://www.clubclio.co.uk
(No subject)
« Reply #17 on: 17:50, Mon 09 February 2009 »
this is taking so long its my fault tbh as i can only work on the car at the weekends lol
hopfully have it running next weekend :)

Bass J

  • 200BHP Senior Member
  • ****
  • Posts: 202
    • View Profile
(No subject)
« Reply #18 on: 20:00, Sun 22 February 2009 »
Well a lot has been done since my last update.

The car runs now :D ...got it running during the week ..then reco came round for the initial startup ...it ran ...it misfired and cut out a few times ...followed by a few carb explosions.

So we are gunna get some new spark plugs in...new fuel filter and new carb gaskets. Also reco is going to get a timing gun just incase the timing is out.

I forgot to get the camera for the running vids :lol:

So after reco left i got some pics.

Exhaust fitted-



Also here is some pics after reco wired it all up notice the cone filter from Rob@backyardracings clio  :tongue_smilie:





Also found the horn and fitted that :)

All is left to do is change of plugs,fuel filter and slap some new gaskets in ...sort out an oil leak. Then reco's coming round with a borrowed timing gun just to check it out.

Then obviously going to do an oil and filter change...get it back on the wheels and it should be ready to go next weekend ...ill defo get a vid then :)

cavsri130

  • 200BHP Senior Member
  • ****
  • Posts: 344
    • View Profile
(No subject)
« Reply #19 on: 21:56, Mon 23 February 2009 »
how  you getting on with the wiring diagram bud? i see you used the turbo coil unit. did you use all the plugs?
im getting my clio on wednesday so the project begins then  :D
IF IN DOUBT FLAT OUT!

Bass J

  • 200BHP Senior Member
  • ****
  • Posts: 202
    • View Profile
(No subject)
« Reply #20 on: 00:42, Tue 24 February 2009 »
my mate wired it up lol.

Didnt use any gtt engine loom. All he did was cut the cables from the coil plug ..grouned the coil pack ..got a 12v power supply from the dash. Then got powers from battery to starter and alternator as far as i kno..then used the clio's dash power connection as usual to battery. Then the soleniod switch wire from the dash loom connected to the startermotor.

my mate reco did it ..so this is what he did from what i could see ..i just left him to i while i done some other work to the car.. guage wise im using aftermarket ones.. the fan im just using a manual switch....Fuel pump wiring needs changed about which i aint sure about LOL.

Hope this kinda helps :lol:

cavsri130

  • 200BHP Senior Member
  • ****
  • Posts: 344
    • View Profile
(No subject)
« Reply #21 on: 10:13, Tue 24 February 2009 »
cheers, ill get ripped into it once i get some time away from the wife  :lol:
IF IN DOUBT FLAT OUT!

Bass J

  • 200BHP Senior Member
  • ****
  • Posts: 202
    • View Profile
(No subject)
« Reply #22 on: 12:30, Tue 24 February 2009 »
where abouts in scotland are you? ..if your near glasgow your welcome to come round and have a nosey at my clio ;)

smithsgtt

  • 200BHP Senior Member
  • ****
  • Posts: 1021
    • View Profile
(No subject)
« Reply #23 on: 13:09, Tue 24 February 2009 »
he's lives in inverness

cavsri130

  • 200BHP Senior Member
  • ****
  • Posts: 344
    • View Profile
(No subject)
« Reply #24 on: 15:13, Tue 24 February 2009 »
yeah i live in inverness, you stalking me smiths??  :shock:
cheers for the invite to peruse over your work but the chances of me getting down there are between slim and nil
IF IN DOUBT FLAT OUT!

Bass J

  • 200BHP Senior Member
  • ****
  • Posts: 202
    • View Profile
(No subject)
« Reply #25 on: 19:55, Tue 24 February 2009 »
haha no probs.

cavsri130

  • 200BHP Senior Member
  • ****
  • Posts: 344
    • View Profile
(No subject)
« Reply #26 on: 18:11, Wed 25 February 2009 »
did you use the 5 or clio subframe. arms etc?
IF IN DOUBT FLAT OUT!

Bass J

  • 200BHP Senior Member
  • ****
  • Posts: 202
    • View Profile
(No subject)
« Reply #27 on: 21:18, Wed 25 February 2009 »
Used the clio subframe wishbones. Clio 16v running gear ...5gtt box (speedo cable is different to the clio...u can use the clio box tho). Oh and if you are using the 5gearbox you will need to drill a hole for the mount.

So i used 1.8 16v clio driveshafts,hubs and suspension..also the front brake setup .

cavsri130

  • 200BHP Senior Member
  • ****
  • Posts: 344
    • View Profile
(No subject)
« Reply #28 on: 06:41, Wed 18 March 2009 »
yeah you were right with the subframe thing, anyway what are you using in the way of fueling and a regulator?
IF IN DOUBT FLAT OUT!

Bass J

  • 200BHP Senior Member
  • ****
  • Posts: 202
    • View Profile
(No subject)
« Reply #29 on: 23:32, Wed 18 March 2009 »
iam using a 1.2 fuel pump ...with a 5gtt regulator ...having fueling problems at the mo ..but ill let you know how i sort it ;)